Using PanMap
Contents

Disclaimer II

1 Introduction 2
  1.1 About this manual . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
  1.2 What is PanMap . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
  1.3 What can PanMap do . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
  1.4 Download of the PanMap software . . . . . . . . . . . . . . . . . . . . . . 3
  1.5 Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

2 Quick Start / The first map 4
  2.1 Start of the program . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
  2.2 Loading the coast line layer . . . . . . . . . . . . . . . . . . . . . . . . . . 4
  2.3 Loading the city layer (point layer) . . . . . . . . . . . . . . . . . . . . . . 6
  2.4 Defining map boundaries . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
  2.5 Controlling map size and scale . . . . . . . . . . . . . . . . . . . . . . . . 8
  2.6 Configuring the city layer . . . . . . . . . . . . . . . . . . . . . . . . . . 9
  2.7 Loading the river layer . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
  2.8 Save your work . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
  2.9 Printing of a map . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
  2.10 Status . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

3 Working with maps 14
  3.1 The layer concept of PanMap . . . . . . . . . . . . . . . . . . . . . . . . . 14
  3.2 Defining a default layer . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
  3.3 Importing tabular data to point layers . . . . . . . . . . . . . . . . . . . . 16
  3.4 Importing vectors . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
  3.5 Import of GF3-data (GEBCO) . . . . . . . . . . . . . . . . . . . . . . . . . 18
  3.6 Designing maps . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
    3.6.1 Add, replace and delete map layers . . . . . . . . . . . . . . . . . . . 19
    3.6.2 Applying layer colours . . . . . . . . . . . . . . . . . . . . . . . . . 20
    3.6.3 Defining point layer layout . . . . . . . . . . . . . . . . . . . . . . . 22
    3.6.4 Color mapping with point layers . . . . . . . . . . . . . . . . . . . . 23
    3.6.5 Defining topo layer layout . . . . . . . . . . . . . . . . . . . . . . . 25
    3.6.6 Selecting projection and map center . . . . . . . . . . . . . . . . . . 25
    3.6.7 Attributes and layout of a map . . . . . . . . . . . . . . . . . . . . . 26
    3.6.8 Selecting scale and size of a map . . . . . . . . . . . . . . . . . . . . 27
    3.6.9 Defining the map area . . . . . . . . . . . . . . . . . . . . . . . . . . 28
Disclaimer

The PanMap software was developed to easily and quickly display georeferenced data in maps. It is distributed by the PANGAEA web server together with various geographic data in PanMap format.

The information system PANGAEA and related software is operated by the Alfred Wegener Institute for Polar and Marine Research and the Center for Marine Environmental Sciences. The operators do not take responsibility for any errors or failures of the software or problems arising from its use, or the use of data retrieved from the software.

PanMap is available for the scientific community and is distributed as Freeware for the operating systems Windows® and MacOS®.


The geographic data available on the PanMap website is to be quoted by the references listed there.

Alfred Wegener Institute for Polar and Marine Research (AWI)
27515 Bremerhaven, Germany

Center for Marine Environmental Sciences (MARUM)
University of Bremen
28334 Bremen, Germany

E-mail: info@PANGAEA.de
1 Introduction

1.1 About this manual

This manual was written as an introduction to using PanMap and as a reference of the Pan-
Map functions. The manual exclusively refers to the Windows® version of PanMap. Fun-
damental knowledge of the Windows® user interface is required for the use of this manual.
The deviations of the Macintosh® version essentially refer to the different handling of the user interface - the desktop, differences in the arrangement of the menus and Apple specific data formats (graphics).

Text or terms from menus or dialog windows of PanMap are typographically emphasized in
the manual: Example. Menu nestings are represented by arrows. The call of the Open
dialog in the File menu is represented in the manual like this: File → Open.

1.2 What is PanMap

PanMap is a computer program for displaying point data and vector data in geographical maps. One could call it a simple geographic information system (mini GIS). It is recom-
mended to use this software in connection with data from the PANGAEA Information Sys-
tem. PanMap was developed for personal computers and is available in a Windows® and a Apple Macintosh® version. PanMap is Freeware.

1.3 What can PanMap do

PanMap displays georeferenced data, i.e. information, that has a geographical reference, in maps. Some common cartographic projections are supported. Map extension (boundaries) and scale are interactively selectable, layout and graphic display of imported data can be defined by the user. PanMap works vector-oriented, raster data can not be displayed by PanMap; a geographical datum cannot be defined.

Georeferenced data is translated into PanMaps proprietary format and is used as a layer. Each individual layer can be processed and arranged separately and be used in various maps. Together with a set of additional map characteristics one or more layers form a PanMap map. These characteristics are for instance: map extension, geographical projection, scale and layout.
1.4 Download of the PanMap software

The PanMap program is available on the PANGAEA webserver:

http://www.PANGAEA.de/Software/PanMap/

On this page you find links to the Windows\textsuperscript{®} version (PanMap.zip) and the Macintosh\textsuperscript{®} version (PanMap.sea.hqx). After clicking on the chosen link, your browser will ask you to give a file name and a location (directory) for the downloaded file. Usually you can acknowledge the pre-set values with Ok. The program archive then is written to your hard disk.

In addition you find a set of data sets in layer format as Zip archives on the download page, which have been prepared for use by PanMap. First load the files for cities (major cities) and rivers (major rivers) to your computer. The file names are: MajorCities.zip and MajorRiver.zip. These layers are generally useful and will by used also in the following map examples. Other layer files, supplied through the PANGAEA web server, can be added to your installation according to requirement.

1.5 Installation

Move or copy the file with the PanMap archive (PanMap.zip) and the files with the city layer (MajorCities.zip) and the river layer (MajorRiver.zip) into a directory of your choice. Open the file with a compression program, which supports the Zip format and unpack the files. After this you can close the compression program.\footnote{Macintosh\textsuperscript{®} users find a document with a guide for unpacking Zip files under MacOS on the PanMap page of the PANGAEA webserver: \textit{How to extract Zip archives on Macintosh.}}

Change into the PanMap directory of your system. With the Windows\textsuperscript{®} version of PanMap you also find two program libraries, which are necessary for working with PanMap, (*.dll)\footnote{Displaying is often disabled by the system.} and a batch script, which deletes temporary PanMap files in the system. Additionally you find a layer file with world-wide coastal lines (Coast.lay), which can be defined as the default layer (see Chapter 3.2, page 15) for PanMap, as with the examples in this manual.

It is recommended to create a directory for your own (or additional) layer files. Move the layer files, which you have downloaded from the PANGAEA server, into this directory and unpack them according to the procedure for the program archive. Now the installation of PanMap is complete and you can start with the generation of maps.
2 Quick Start / The first map

2.1 Start of the program

After installing of the program and the coastline layer you can create a first map. Open the PanMap directory on your system and double-click the program icon of PanMap.

The PanMap window opens (Fig. 2). At the top margin of the window to the right of the PanMap logo icon you find the menubar. Below the menubar, you find the toolbar with eight buttons for important and frequently used PanMap functions. You may move the menubar by using drag and drop techniques.

After starting PanMap, a map of the world in Mercator projection appears within the PanMap window. This map shows the coastline between 83° northern latitude and 83° southern latitude. This set-up is due to the fact that the coastal lines layer Coast.lay is defined as the default layer for the PanMap distribution. This layer will be used for every new map you generate unless you delete it from your set of layers or define a different default layer.

2.2 Loading the coast line layer

If the coastal line does not appear as described after the program starts, you are working with an installation, in which the coast line layer is not defined as the default layer. In this case...
you can load this layer manually. You can define this layer as the default layer - described
in Chapter 3.2, "Defining a Default Layer" - , or you can load this layer as part of a current
map.

Since loading of PanMap layers is a frequently used function, there is a button for this func-
tion in the toolbar. Move the mouse pointer over this button (a note "Edit the layers of the
current map" appears in the status bar) and click on it. This opens the MAP PROPERTIES
dialog (Fig. 3). On the left of this dialog window there is a white box, in which currently
loaded layers are listed. The coast line layer would also be listed, if it were defined as default
layer. As in our example this is not the case, the field is empty.
2.3 Loading the city layer (point layer)

To load the PanMap layer, containing the cities, you proceed in the same way. Click on the button for processing map layers, the MAP PROPERTIES dialog appears. If you click the ADD button to the right of the layer list, a file select box opens (SELECT A LAYER, Fig. 4).

Select the file Cities.lay from the directory where you store the layers. If you followed the example installation as described in Chapter 1.5 "Installation", it is the directory Layer in the PanMap directory. Select the file Cities.lay and click on OPEN to load the file. The layer you have just loaded appears in the list below the Coast.lay. For now, leave all other option of this dialog on the default values and click OK; the coastal lines will now be displayed on your map.

With the standard settings the location of the cities on the map are represented as red points. The colour of the points was already indicated by a red box to the right of the CITIES.LAY entry in the list. In the next paragraph you will modify the indicators for the cities on the map. For the sake of clarity you will work on a larger scale map, not a world map, i.e. you will define a smaller mapping area (boundaries).
2.4 Defining map boundaries

For determining map boundaries, i.e. the enlargement of the area mapped, a button in the toolbar (magnifying glass) is available. You activate this function by clicking on this button. Move the mouse pointer to a corner of the new map area and create a rectangular frame around the area by dragging the mouse to the opposite corner while keeping the mouse button pressed. In the following examples we will use an area covering the Iberian Peninsula and adjacent areas (Fig. 5).

Directly after releasing the mouse button, the new area will instantly be drawn. The menu \texttt{EDIT $\rightarrow$ RESTORE LAST SECTION} will always restore the previous map extend. Directly after you released the mouse button, the new map instantly gets drawn. To go back to the global map, you have to click the button for the global view in the toolbar.\footnote{Attention! When working with voluminous layers, the drawing of the global view may take quite a while.}
2 Quick Start / The first map

2.5 Controlling map size and scale

With the magnifying glass you can quickly and intuitively choose the area and the scale desired for your map. In addition, it is possible to give an accurate scale for the map. In the previous example for instance, a scale of about 1:13 Mio. results from the area selection with the magnifying glass. This scale is now to be defined accurately to this value. This is achieved by using **EDIT → CHANGE MAP SIZE** (Fig.6).

You get the dialog window for adjusting the scale and map size. Correct the displayed value to 13000000 by typing in the field and click the **OK** button. The entry under **SIZE** instantly indicates the new physical size of your map. With the **FIT TO PAPER** button, you adjust the map scale to the physical size of the page.

Fig. 5: Defining map boundaries
2.6 Configuring the city layer

Now after you have selected the new map area, the representation of the cities on the map will be redesigned and optimized. Until now the geographical locations of the cities are marked only by red points on the map. Naturally one would also like to plot the names of the cities into the map, change appearance of the markers and make an entry into the legend of the map. The names of the cities are provided by the layer Cities.lay, and they can be made visible at any time.

This is configured by the Map Properties dialog, which you either call from the menu-bar (EDIT之中EDIT MAP), or by clicking the appropriate button in the toolbar.

In the Map Properties dialog you double click the Cities.lay entry in the layer list (or you mark this entry and click on the Edit button to the right). You will be presented with the Point Layer Properties dialog, which lets you determine the layout and appearance of point layers (Fig. 7).

The Point Layer Properties dialog has three fields:

- **Legend** to determine a legend entry,
- **Symbol** defines a symbol for the representation of the locations on the map and
- **Label** to define the labels to be drawn at the point markers on the map.

In **Legend** you can enter the text, which is to appear in the legend. In this example the text would be *Cities*. Select a type of marker under **Symbol/Shape**, for example **Circle, filled**, set the size of the marker to 4 and leave the marker colour on red. In case you wish to set a different colour for the representation of the point markers on the map, click the red **Select** button beside the **Color** entry. You will then be prompted with the system specific dialog for the selection or definition of colours.

Now, select the label (annotation) of the point markers on the map. Click the arrow of the attribute selection list and select the entry **Name**. This will select city names as the label attribute to appear in the map beside the point marker.

From the attribute selection list, select the value 12 in the field **Fontsize**, and Arial in the **Font** field. Leave the font colour on black. Now, click on the **OK** buttons of the
Fig. 7: Configuring point layers

POINT LAYER PROPERTIES dialog and the MAP PROPERTIES dialog. Your map should now look like in figure 8.

For the appearance of the example map some additional features can be changed and adapted. These features are controlled by the MISCELLANEOUS ATTRIBUTES dialog, which is activated through the menubar: EDIT → CHANGE MAP ATTRIBUTES (Fig. 9).

For our example, type in a title for the map under HEADER. Leave the selection of the map title font family and the font size on the suggested values and activate the plotting of scale information and legend entries by clicking the check boxes under OTHER TEXT.

In the NET GRID area (right part of the dialog) select 5° for the graticule. You do this by clicking on the current value or the arrow of the appropriate drop down list next to LATITUDE SPACING and LONGITUDE SPACING. Highlight the desired value 5°. Leave the line colour on the displayed grey tone and the line width on the value of 1.

Click OK, the redefined attributes will be cascaded at once. You can now easily reposition the legend with the direct selection tool and optimize the position of the point marker annotations. With this tool activated you simply drag these features with the mouse. Select the direct selection tool from the toolbar (arrow) and click an annotation. Keeping the mouse button pressed, drag the annotation to the desired place on the map. If necessary, PanMap automatically inserts a lead between the text and point marker. Proceed likewise to reposition the legend. The example map should now look like in figure 11.

The position of annotations and legend, which you have defined with the direct selection tool, will be lost if you save the map and re-open it. These properties are not saved.
Fig. 8: Map with annotated locations

Fig. 9: Miscellaneous attribute dialog
2.7 Loading the river layer

To load the river layer you proceed the way you did with loading the city layer:

ADD → RIVER.LAY → OPEN → OK

Define the layout characteristics of the river layer with the MAP PROPERTIES dialog. Highlight the River.lay entry in the LAYER list and select the EDIT button or double click the River.lay entry in the list.

You are prompted with the TOPO LAYER PROPERTIES dialog (Fig. 12). Enter Rivers in the LEGEND text box, and leave the line width on 1. Select a blue tone for the colour of the rivers on the map. Now click OK in the TOPO LAYER PROPERTIES dialog and in the MAP PROPERTIES dialog also. The rivers will appear on the map as blue lines.

2.8 Save your work

Save your work as usual with the menu FILE → SAVE AS... Give a name for the map (e.g. Ibero.map) and click the SAVE button. The map will be saved with all features and graphical attributes. Scale, area, projection, map attributes and layers incorporated belong to a saved map. You may later re-open the map and continue working on it, provided the paths to the layers used in the map are still the same. To open the map again, use the OPEN... dialog in the FILE menu. From the FILE menu you can select a map to open also from the list of the four most recent processed maps.

2.9 Printing of a map

First make sure that the current page setup (page size, orientation, colour or gray tone printing, etc.) corresponds to that of the attached printer (FILE → PAGE SETUP...). If this is the case, the map can be printed by selecting FILE → PRINT....

Fig. 10: Moving annotation

---

5The Windows® version of PanMap needs the extension *.map.
Fig. 11: Map including annotation and high-resolution coast line
3 Working with maps

3.1 The layer concept of PanMap

In chapter 2 "Quick start/ The first map" you became acquainted with the layer concept of PanMap. You merged ready-made layers, a point layer and a vector layer, into your map and determined the layout of the map and the layers. In this section additional functions and options of handling layers are presented and described. These are – for instance – the definition of a default layer, but more importantly the options for importing your own or third party data into the program and then converting it into PanMap layers. PanMap provides corresponding import and conversion functions.

Each map consists of one or more layers. Both point and vector layer can be combined in a single map and each layer can be configured individually.

There are two types of layers: point layers and vector layers. You know these layer types from the tutorial as the cities layer and the river layer. Both layer types differ in the type of the data they contain.

With point layers this data is a variety of geographical locations, defined by Phi (geographical latitude) and Lambda (geographical longitude), that can be linked to other data. The
locations in the point layer *Cities.lay*, for instance, have labels (the name of the city), as an additional record. It is also possible to store the numbers of inhabitants of the cities as a record of each point in this layer and show this information on the map.

With PanMap’s vector layers line information is kept geo-referenced. Not always is the direction of a line of importance in the real world (for example with topographical contours, or with political boundaries) and therefore needs no further consideration. In a PanMap vector layer however all lines do have a direction, i.e. a starting point and an end point.

### 3.2 Defining a default layer

With PanMap the term *default layer* defines an arbitrarily selectable layer or a PanMap map, which is automatically imported and displayed starting the program or creating a new map. Therefore the user can load important data, which are merged frequently or always in his or her maps up front. The PanMap distribution under Windows® is configured to load the coast line layer (a vector layer) as the default layer.

This layer is useful for many mapping tasks. But it could be just as useful to select a different default layer. For example for creating sets of similar maps. You may also switch off the default layer function completely if you do not want this feature.

In order to define the default layer, select the menu **FILE → PREFERENCES**. On the top left side of the **PREFERENCE** dialog you can switch the default layer feature on and off by clicking the check box (Fig. 13). If this option is activated, a black check mark appears in the box.

![Fig. 13: File selection](image)

On the right side of the *default layer* entry there is a button, which shows the path to the current default layer. Click on this button in order to enter the dialog for selecting a default layer. With this dialog you have the option of selecting a layer file (extension *.lay*) or a
map (extension .map). These two options are available depending on the file type indicated in the lower area of the file select dialog. Change the file type by clicking the arrow to the right of this field. The definition of the default layer only becomes effective when creating a new map. Select menu File → New or leave the program and start again.

3.3 Importing tabular data to point layers

Tabular point data can be imported as text files. Column separator is a tabulator (char 9), a common exchange format for tabular data. Such text files can also be retrieved through the web interface of the PANGAEA information system. Data can be exported with geographical coordinates and imported directly into PanMap.

In the following example a file with locations and names of Spanish cities is imported and converted into a layer. As a contrast to the cities layer from the tutorial this file also has additional information on the population rank as a data record. This classification is expressed in size classes from 1 to 6 and kept in the file as the fourth column (after geographical latitude, longitude and city name):

<table>
<thead>
<tr>
<th>Latitude</th>
<th>Longitude</th>
<th>Name</th>
<th>Rang</th>
</tr>
</thead>
<tbody>
<tr>
<td>39.57416</td>
<td>2.65499</td>
<td>Palma</td>
<td>1</td>
</tr>
<tr>
<td>39.78666</td>
<td>2.70472</td>
<td>Sóller</td>
<td>6</td>
</tr>
<tr>
<td>40.00166</td>
<td>3.84166</td>
<td>Ciudadela</td>
<td>2</td>
</tr>
<tr>
<td>39.88777</td>
<td>4.26194</td>
<td>Mahon</td>
<td>6</td>
</tr>
<tr>
<td>...</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>38.87055</td>
<td>-1.08833</td>
<td>Almansa</td>
<td>3</td>
</tr>
<tr>
<td>39.00111</td>
<td>-1.85222</td>
<td>Albacete</td>
<td>4</td>
</tr>
<tr>
<td>42.04888</td>
<td>-8.64083</td>
<td>Túy</td>
<td>5</td>
</tr>
</tbody>
</table>

The first two entries in each line represent the geographical coordinates of the cities in decimal degrees. Then follows the designator or name for the location and then the population rank of the place in arbitrary size classes from 1 to 6. The file should have a heading containing the column names.

One can export such tables from most spreadsheet programs or data base systems. They can of course also be created with a text editor. Further columns with additional information can be added to this type of files for the visualization in PanMap. To import such tables and convert them into the layer format you select File → Import Spreadsheet ... (MacOS: File → Import → Point data ...).

Once you do so, the file is read and the dialog for saving the respective new layer opens. Give this new layer a name with the extension *.lay and click OK.
Another dialog opens automatically (Fig. 14): within the ATTRIBUTE EDIT dialog the names of the columns (the column headers of the text file) appear under **Name**, together with a suggested format of the data under **Type**. For geographical latitude and longitude this format is floating point numbers (**Float**), for city names the format is *character string* (**String**), and the suggested format for **Rank** also is **Float**. You may alter this into the **Integer**-format, since we know that these data (the population rank in this file) only take integer values. After confirming by clicking **OK**, the text file is converted to a layer. In Chapter 3.6.3, *Defining Point Layer Layout* further options will be described for the layout of point layers.

### 3.4 Importing vectors

Importing vectors to layers is quite similar to importing point information from spreadsheet type text files. However, the menu **FILE -> IMPORT COURSE** is available for this (under MacOS: **FILE -> IMPORT -> SINGLE VECTOR DATA**). But when converting vector files into a vector layer only pairs of geographical co-ordinates in the source file are recognized and processed. These co-ordinates form the way points for the line feature to be represented in the map. Additional columns or data are ignored when using the **import-vectors** function of PanMap.

Select the menu **FILE -> IMPORT COURSE**. Select your text file with the co-ordinates for the line feature (e.g. a track, a profile or a ship course) and click **OK**. Now you enter the **SAVE FILE AS** dialog. Type in a name for the newly generated layer and confirm
3 Working with maps

by clicking OK. The co-ordinates listed in the source file are connected on the map with a line, exactly in the same order they are listed in the file.

The newly generated layer has to be merged into your map (EDIT → EDIT MAP). You may also call this dialog by clicking the respective button in the toolbar. Within the Layer Manager you can load the layer into your current map and define the layout and other characteristics of this layer. These are line width and colour for PanMap vector layers. You can find more information on this in Chapter 3.6 Defining topo layer layout.

3.5 Import of GF3-data (GEBCO)

For importing sets of vectors the function File → Convert GEBCO Data... is available (under MacOS: File → Import → Multi Vector Data...). The name of this function is derived from the ASCII export format, which is used by GEBCO (General Bathymetric Chart Of the Oceans) for vector streams. This is an ASCII format, which designates a single-line header record and an arbitrary number of following records or lines with pairs of coordinates for each vector.

In the header two dates are stored:

1. A numeric code for the following vector, which can consist of up to 6 digits and
2. the number of records, which describe the respective vector.

Both are separated by a tabulator (char 9). The header is followed by pairs of coordinates. The geographical latitude as floating point value, a tabulator, the geographical longitude likewise as floating point value. Any series of vectors, which adhere to this format, can be imported and converted into a PanMap layer.

The PanMap function File → Convert GEBCO Data... is particularly suitable for the import of homogeneous or similar vectors of different locations. Typical examples for this type of vectors are topographic or bathymetric contours. In this case the code in the header record of each vector would contain the e.g. 'meter above sea-level' or the 'water depth'.

Select File → Convert GEBCO Data... from the menubar to select an ASCII file with the format described above. You are then prompted for a name of the newly created layer, as with the conversion of tabular data into point layers. Type in the name and confirm by clicking OK. The dialog Import Topological Data then follows to control further processing of the source data. If the source file contains vectors with different codes (designations), then a layer can be created for each of these vectors. Matching vectors will be stored in the same layer and the resulting classes of layers may be represented or styled differently on a map. This, for instance, is useful if you plan to use colour coded contours in a map.

When importing vector data you can also reduce the resolution of the vector (meaning the number of vertices), for example in order to quickly display highly resolved lines in small-scale maps.

6For an example of the GF3-format see the appendix.
You have now become acquainted with one of the most important functions of PanMap: importing of external data for further processing in maps. All data which you have prepared this way, are now PanMap layers and may be combined with any map you generate. Depending on the nature of the data, point or vector information, the resulting layers are point layer or topo layer, for which different layout and display options are available.

### 3.6 Designing maps

Due to the proceeding chapters you already know how to convert your own data into both layer types (point and vector) and how to prepare the data for plotting within PanMap. The organization of layers of a map and the characteristics and the appearance of the layers, are controlled via the **Map Properties** dialog.

#### 3.6.1 Add, replace and delete map layers

A map consists of one or more layers, that can be combined as required. A part from the possibly defined default layer (chapter 3.2, *Defining a default layer*) further layers must be selected explicitly. This is done via the **Map Properties** dialog which can be called from the menubar or by clicking the button in the toolbar.

On the left side of this dialog you find a list of already loaded layers. The default layer is also listed there. In the upper right area of this dialog you find buttons for loading (**ADD**), removal (**REMOVE**), replacing (**REPLACE**) and editing (**EDIT**) of layers.

**Add a layer**

To load a new layer, click the **ADD** button in order to call the **Select a Layer** dialog. Open the directory, in which the desired layer is stored, highlight the appropriate entry (file name) and click on **OPEN**. The layer is loaded and appears in the layer list. After confirming with **OK** the new layer will be displayed in the current map.\(^7\)

---

\(^7\)Attention! Larger layers can take a bit longer to be displayed depending on the capacity of your computer.
3 Working with maps

Fig. 16: The 'Map Properties' Dialog

Remove a layer
Select a layer from the layer list of the Map Properties dialog and click the REMOVE button. The layer is removed from the list and the current map is updated accordingly.

Replace a layer
Select a current layer in the list and click the REPLACE button. Select a new layer from the file select dialog as you did with loading a new layer, confirm with OK. The new layer will replace the highlighted one in the layers list. With REPLACE the graphical attributes as defined for the layer to be replaced, are applied to the new layer.

3.6.2 Applying layer colours

For the colour coding and the selection of line width and legend entry of vector layers, you click the EDIT button of the Map Properties dialog. You may define these characteristics for each layer individually or for a set of layers which are topologically related (contours for instance) in one step. Open the Map Properties dialog and select a vector layer. Click the EDIT button. You are prompted with the Topo Layer Properties dialog and are ready to define legend entry, colour and line width for the vector layer (Fig. 17).

If you have several homogeneous vector layers in your map, you can also define a colour gradation (COLOR RAMP) for these layers. This is suitable for topographic contours.

Select a set of layers from the list in the Map Properties dialog holding the SHIFT or CTRL key on the keyboard down while clicking (highlighting) the layer entries, or by
keeping the mouse button pressed and dragging the mouse over the layer entries. Click on the EDIT button. You can select colours for the first and the last layer by clicking the buttons FIRST COLOR and LAST COLOR. Then click the corresponding select field, choose a colour and confirm your choice with OK. The colour ramp will be assigned automatically.
3.6.3 Defining point layer layout

The representation of a point layer is likewise controlled by the MAP PROPERTIES dialog. Mark a point layer in the list and click the EDIT button. You receive the POINT LAYER PROPERTIES dialog (Fig. 19).

This dialog provides three areas for the plotting and layout of point layers: LEGEND, SYMBOL, and LABEL.

In the area LEGEND type the name of the layer, you want to appear in the legend, into the text box. In the area SYMBOL you can determine the graphical attributes of the markers or symbols on the map.

SHAPE is an drop down menu where you can select from different marker shapes. All marker shapes or types can be applied to the layer as outlined or filled forms.

Under SIZE you can determine the size of the used marker with values from 0 to 10. Either type the desired value in the appropriate textbox or select from the scroll list to apply the desired value.

Under COLOR the colour of the marker is defined. The button SELECT besides the colour entry displays the current colour of the marker. Click the SELECT button to define another
colour for the marker. You will obtain the dialog for selecting colours, specific to your operating system.

3.6.4 Color mapping with point layers

PanMap also provides an extended function for the definition of colours for point markers. The marker colours on the map can be defined according the values or data, belonging to the respective sites.

You open the **COLORIZE TABLE – DEFINE A COLOR MAP** dialog for point layers by clicking the **COLOR MAPPING** button of the **SYMBOL** area (MacOS: **MARKER**) of the **MAP PROPERTIES** dialog. This dialog defines the graphical attributes of the point markers of a layer as a function of associated values or data. With the example of the point layer for Spanish cities, the size class information (Classes 1 to 6) will be used as criteria for the colour of the markers. Each class will be represented on the map by a different colour.

![Color map dialog](image)

**Fig. 21: Color mapping with point layers**

Within the upper area of the **COLORIZE TABLE – DEFINE A COLOR MAP** dialog you find a drop down menu where the point attributes of the layer are listed (Fig. 21). Select the attribute which holds the data that will control the colour scheme for the markers from this list. The data itself has to be in a numerical format. Under **ATTRIBUTE** the available attributes of the currently selected point layer are listed. Generally, and also in our example, the attributes Latitude, Longitude and Rank could be chosen for the colour coding of the markers, as these attributes are numerical.
With this example you select the rank (*Rang*) as the attribute to be used for colour coding. The idea is, that the city locations appear on the map in different colours depending on their relative size (the rank value) on the map.

First select a **BASE COLOR**. This is the colour, with which all markers on the map are represented, whose values lie outside the range of the colour ramp defined. This can for instance be useful when importing data, where not all attribute fields are filled with values, or not all of the cities have entries for the rank. Such cities will be displayed with an uniform colour: the **BASE COLOR**.

Below the **BASE COLOR** button there is a text box and a colour selection button. You may define certain size classes here (> =, meaning larger or equal) with different colour representation. For example, type in a value of 5, select a red tone and click **ADD/CHANGE**. Now your definition will be part of the current colour map. Continue like this for the other size classes. Type in 4, select a green colour tone, and click **ADD/CHANGE**. Repeat this accordingly for the values of 3, 2 and 1 until the desired colour map is complete.

For continuous values, like here in the example from 1 to 6, you can also select the **MAKE RAMP**-function. Click on the appropriate button on the right side of the dialog, and select a starting colour and a final colour for the colour tone, for example gray and black (Fig. 22). For the first value which will be covered by the ramp, type in the value 1 (**FIRST VALUE**), for **STEP INCREMENT** also type in 1, and for the last value (**LAST VALUE**) to be considered by the colour Ramp type in 6. By doing so, you required the entire scope of values of the Rank attribute to be covered by the ramp. Now click **OK**, the ramp will be calculated and transferred to the dialog **COLORIZE TABLE – DEFINE A COLOR MAP**.

![Generate new color map](image)

**Fig. 22: Making color ramp for point layers**

There is a variety of options for the definition of colours and colour maps applied to point layers with numerical attributes. These options provide for specific and deliberately designed representations of point layers or a quick relation of values to colour codes for Pan-Map maps.
### 3.6.5 Defining topo layer layout

Topo layers are PanMap layers with line or vector information. In order to define the graphic characteristics of a Topo layer, you open the [MAP PROPERTIES] dialog as described for the definition of Point layers properties, select a Topo layer from the list (here the river layer from the tutorial) and click on [EDIT].

In the [TOPO LAYER PROPERTIES] dialog (Fig. 23) you write the entry for the legend ([LEGEND]), select a line width for the line on the map ([LINE WIDTH]), and a colour ([COLOR]). Thus the characteristics of a Topo layer are defined.

![Fig. 23: The 'Topo Layer Properties' Dialog](image)

### 3.6.6 Selecting projection and map center

So far you worked in the examples with the Mercator projection. PanMap however makes further cartographic projections available:

- Mercator
- Lambert
- Kartesisch
- Mollweide
- Polar Stereografisch (North)
- Polar Stereografisch (South)

In this manual the different projections and their properties will not be discussed. Definition of a geographical datum is not possible in PanMap.

The selection of a projection is done within the [MAP PROPERTIES] dialog, which you call from the menubar ([EDIT → EDIT MAP]) or from the toolbar button. Select a projection from the drop down menu [PROJECTION] and click [OK]. Your map now is drawn with the selected projection.

This projection remains as characteristic of your map even after saving and re-opening the map. The selected map projection is also preserved, if you select another or a new map area with the magnifying glass tool.

![Fig. 24: The Projection Dialog](image)
Apart from the projection you can also determine the central meridian of your map in the Map Properties dialog. For this the function Map center is available (Fig. 25).

You can select values between 180° west and 180° east for the central meridian with the slide rule at the lower area of the Map Properties dialog (Steps of 10° with the arrows and steps of 1° by clicking on the gray block). The value displayed is the central meridian of the projection.

Attention: Every time a new central meridian is selected the map is re-drawn in the global view.

3.6.7 Attributes and layout of a map

Most graphical attributes and layout characteristics of a map are bound to the layers used. (see chapter 3.6.3, "Defining point layer layout" or chapter 3.6.5, "Defining topo layer layout"). With the Miscellaneous Attributes dialog Fig. 26) you define the title of the map, the layout of legend and scale bar and the graticule of the map. Select the menu Edit → Change Map Attributes ... from the menubar.

The Miscellaneous Attributes dialog has three areas for the definition of the attributes of a map: HEADER, OTHER TEXT and NET GRID. Under HEADER you find a text box, into which you type a title for the map. Below that you find a drop down menu to select font family and font size for the title.
3 Working with maps

Within the area **Other Text** you activate legend and scale bar for a map by clicking the check boxes **Show Scale Information** and **Show Legend**. Check marks appear in the boxes indicating that the options have been activated. Below the control for legend and scale you find menus for font family and font size for legend and scale.

In the **Net grid** area the attributes for the display of a graticule to the map are defined. Under **Latitude spacing** and **Longitude spacing** you find drop down menus to determine the distance between graticule lines in north/south and east/west direction. Different gradations from 30 degrees to 0.001 seconds are available (Fig. 27). If you select the option **None**, no graticule lines are drawn for the longitude or latitude.

![Fig. 27: Changing the distance between graticule lines](image)

With **Line color** and **Line width** you can select the respective graphical properties for the graticule lines. The graticule is annotated at the boundary of the map. The properties (font family and font scale) for the annotations follow the values of the **Other Text** menu.

### 3.6.8 Selecting scale and size of a map

The menu **Edit → Change Map Size** serves for the adjustment of the scale of a map. It offers two options to determine the scale: by typing in the scale value into the text field, or by clicking the **Fit to Paper** button.

When you type in the scale or change the value in the text field the physical size of the map is adjusted directly under **Size**. You can vary the scale of the map to come up with the desired size of the map. If you click the button **Fit to Paper**, the scale is adjusted automatically to fill the paper size given by the **Page Layout** dialog. This is also the default when creating new maps (**File → New**) or when starting PanMap.
3.6.9 Defining the map area

In the tutorial and in the chapter on "Working with layers" you have already worked with map areas. PanMap offers more than one option to determine the map area, meaning the geographical boundaries of the map: the "magnifying glass" tool and the menu options RESTORE LAST SECTION and SHOW WHOLE WORLD under the EDIT menu. Under MacOS you also have the option of entering fixed coordinates in the SELECT AREA function of the layer manager.

Click the magnifying glass tool in the toolbar to determine the map area by clicking in the map and pulling of the mouse keeping the mouse button pressed. The previous map area can be restored by selecting EDIT → RESTORE LAST SECTION. You can always go back to the global view by clicking the button for the global view in the toolbar.

4 Supplementing PanMap tools and functions

4.1 Toolbar and status line on and off

Select the VIEW menu from the menubar. There you can switch on and off the TOOLBAR and the STATUS BAR. This function is not available under the MacOS.

4.2 Label and pop-up information

Data from a point layer can be made visible permanently on a map as annotations of the markers. Open the POINT LAYER PROPERTIES dialog from the menu EDIT → EDIT MAP or select the button from the toolbar and define a label. To achieve this select the appropriate attribute from the drop down menu. Define a font family and a font size for the labels and confirm your adjustments by clicking OK.

Data from an active point layer can also be retrieved in a map with the info pointer tool (i). Click on a marker on your map with this tool activated. The attributes of this point are displayed with their values in a pop-up field. If you click on a place on the map outside of the point markers with this tool, only the geographical coordinates are displayed in decimal degrees.

The relative position of the label in respect to it’s marker can be adjusted manually with the direct selection tool. Select this tool from the toolbar and drag the label to the new position by holding the mouse button down and moving the mouse pointer to the desired place.

4.3 Zoom

You may zoom a map in and out by way of three buttons of the toolbar. The first of these buttons zooms the display of the map out, the second zooms in. If you select the third button
the zoom factor is setback to 100%, e.g. the size of the map on the screen is almost exactly the physical size of the map.

4.4 Operating on several maps in the same session

You can work with more than one map during a PanMap session. You can move a map to the front or back (with respect to the other maps) by way of the WINDOW menu. You can also choose from different window arrangements (CASCADE, TILE, ARRANGE). This is not available under MacOS.

4.5 Exporting maps

PanMap maps can be used as graphic files in other programs. In Windows® you select the COPY entry from the EDIT menu (or CTRL-C). A copy of the map will by transferred to the Windows® Clipboard. This copy can be transferred by the PASTE function in the Windows® EDIT menu into an open document of a graphic program or word processor.

With the Macintosh® version of PanMap you select the EXPORT PICT... entry from the EDIT menu to save the map in a Macintosh specific graphic file format (PICT). The PICT-graphic has to be reduced to the required size.
A File formats

A.1 Point data

For the generation of point layers, data from spreadsheet programs can be imported by selecting the menu **FILE → IMPORT SPREADSHEET ...** (MacOS: **FILE → IMPORT → POINT DATA ...**). These data records must be stored as text files (ASCII) in the following format:

All values in one line are seperated by tabulators (char 9), lines are seperated by <cr>/<lf>. The first column must always contain the value for the geographical latitude of the site in decimal degrees. The second column holds the geographical longitude of the site in decimal degrees.\(^8\) The file can have a leading header line with column designators, seperated by tabulator.

<table>
<thead>
<tr>
<th>Tab. 2: Format of a point data file</th>
</tr>
</thead>
<tbody>
<tr>
<td>latitude</td>
</tr>
<tr>
<td>nn.nnn</td>
</tr>
<tr>
<td>nn.nnn</td>
</tr>
<tr>
<td>nn.nnn</td>
</tr>
<tr>
<td>nn.nnn</td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

\(^8\)Conversion of other Latitude/Longitude formats can be made with PanTool. PanTool is available under [http://www.pangaea.de/Software](http://www.pangaea.de/Software).

A.2 Line data

To import single vectors and convert them into topo layers, select **FILE → IMPORT COURSE** (MacOS: **FILE → IMPORT → SINGLE VECTOR DATA**). The data format for suitable files corresponds to the format above, however only the columns for latitude and longitude are required. Attribute columns are not necessary, and – if present – are ignored.

A.3 GEBCO / GF3-Data

To import groups of lines or vectors, you select **FILE → CONVERT GEBCO DATA ...** (MacOS: **IMPORT → MULTI VECTOR DATA ...**).

Suitable files are text files (ASCII) in which each vector is described by a header record and following records of vertices. The header record for each vector comprises of a numerical code with up to six digits, a tabulator and the number of \(n\) vertices for the vector to follow. Then \(n\) records with decimal degree values for the geographical latitude and the geographical longitude of the vertices, separated by a tabulator. The number of vectors in the file is not limited, likewise the number of vertices per vector.
### Tab. 3: Example of the GEBCO GF3 format

<table>
<thead>
<tr>
<th>Layer</th>
<th>Columns</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000</td>
<td>4</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
</tr>
<tr>
<td>nn.nnn nn.nnn</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
<td></td>
</tr>
<tr>
<td>nn.nnn nn.nnn</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
<td></td>
</tr>
<tr>
<td>nn.nnn nn.nnn</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
<td></td>
</tr>
<tr>
<td>nn.nnn nn.nnn</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
<td></td>
</tr>
<tr>
<td>1500</td>
<td>3</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
</tr>
<tr>
<td>nn.nnn nn.nnn</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
<td></td>
</tr>
<tr>
<td>nn.nnn nn.nnn</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
<td></td>
</tr>
<tr>
<td>nn.nnn nn.nnn</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
<td></td>
</tr>
<tr>
<td>2000</td>
<td>7</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
</tr>
<tr>
<td>nn.nnn nn.nnn</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
<td></td>
</tr>
<tr>
<td>nn.nnn nn.nnn</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
<td></td>
</tr>
<tr>
<td>nn.nnn nn.nnn</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
<td></td>
</tr>
<tr>
<td>nn.nnn nn.nnn</td>
<td>&lt;cr&gt;&lt;lf&gt;</td>
<td></td>
</tr>
<tr>
<td>...</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>